pipのインストールに失敗する「Error: Unable to find a match: python-pip」が出る場合の対処

Python プログラミング

yum -y install python-pipでpipがインストールできると聞いたのですができませんでした。

解決方法を書きます。

pipインストール時のエラー内容

yumでのインストール時に以下のようなエラーになります。

# yum -y install python-pip
Failed to set locale, defaulting to C.UTF-8
Last metadata expiration check: 0:03:14 ago on Sat Jan 25 17:54:09 2020.
No match for argument: python-pip
Error: Unable to find a match: python-pip

翻訳

ロケールの設定に失敗しました。デフォルトはC.UTF-8です
最終メタデータ有効期限チェック:0:03:14前(土1月25日17:54:09 2020)
引数が一致しません:python-pip
エラー:一致するものが見つかりません:python-pip

インストール可能なパッケージを確認する

python-pipという名前だと検索可能なパッケージが無いようなので、似たものがないか探します。

# yum list | grep python | grep pip
Failed to set locale, defaulting to C.UTF-8
platform-python-pip.noarch                           9.0.3-15.el8                                      @System
python3-pip-wheel.noarch                             9.0.3-15.el8                                      @System
python2-pip.noarch                                   9.0.3-14.module_el8.1.0+219+cf9e6ac9              AppStream
python2-pip-wheel.noarch                             9.0.3-14.module_el8.1.0+219+cf9e6ac9              AppStream
python3-apipkg.noarch                                1.5-6.el8                                         epel
python3-pip.noarch

python2-pippython3-pipというのがあるようです。

python3-pipをインストールしてみる

python3-pipをインストール。

# yum -y install python3-pip
Complete!

できました。

以上です。

コメント/ピンバック

タイトルとURLをコピーしました